Hoe fatale fout repareren: maximale uitvoeringstijd overschreden in WordPress

17 jan 2020 | Tutorial

Zie je ‘Fatale fout: maximale uitvoeringstijd van 30 seconden overschreden’ op het scherm wanneer je probeert een WordPress-plug-in of -thema bij te werken?

Dit probleem treedt meestal op wanneer het lang duurt voordat een PHP-code in WordPress wordt uitgevoerd en de maximale tijdslimiet bereikt die door de WordPress-hostingserver is ingesteld. De tijdslimiet is belangrijk omdat deze helpt misbruik van serverbronnen te voorkomen.

In dit artikel laten we je zien hoe u de fatale fout kunt oplossen: maximale uitvoeringstijd overschreden in WordPress.

Waarom treedt maximale uitvoeringstijd overschreden fout op?

WordPress is hoofdzakelijk gecodeerd in de PHP-programmeertaal. Om webservers tegen misbruik te beschermen, is er een tijdslimiet ingesteld voor hoe lang een PHP-script kan worden uitgevoerd. De werkelijke tijdslimiet varieert tussen hostingbedrijven, maar meestal wordt de maximale uitvoeringstijd ingesteld tussen 30 – 60 seconden, omdat dat meestal voldoende is om een ​​goed PHP-script uit te voeren. Wanneer een script de maximale uitvoeringstermijn bereikt, resulteert dit in een maximale uitvoeringstijd overschreden fout.

Maximale uitvoeringstijd van 30 seconden overschreden fout in WordPress

Vaststelling van maximale uitvoeringstijd overschreden fout
Hoewel de maximale uitvoeringstijd overschreden fout een ‘fatale fout’ wordt genoemd, is het een van de meest voorkomende WordPress-fouten en je kunt dit eenvoudig oplossen. Afhankelijk van wanneer en waar de fout wordt geactiveerd, kan WordPress een foutbericht weergeven aan de websitebezoekers.

Dit is onderdeel van de functie voor fatale foutbeveiliging die is toegevoegd in WordPress 5.2. Je ontvangt mogelijk ook een e-mail waarin staat welke plug-in (als een plug-in de fout heeft veroorzaakt) het probleem heeft veroorzaakt. De e-mail zal ook een speciale link bevatten, waarmee je je kan  aanmelden bij WordPress met ‘Herstelmodus’.

Herstelmodus

Hier kan je de plug-in die de fout veroorzaakt eenvoudig deactiveren of verwijderen. Als je een plug-in echter niet wilt deactiveren, kan je de onderliggende oorzaak verhelpen die de fout heeft veroorzaakt. Om de fout op te lossen, moet je het .htaccess-bestand handmatig bewerken en een eenvoudige coderegel toevoegen.

Maak eenvoudig verbinding met uw website via een FTP-client.

Het .htaccess-bestand bevindt zich in dezelfde map als / wp-content / en / wp-admin / folders.  Als je bijvoorbeeld FileZilla als FTP-client gebruikt, kan je deze vinden in het gedeelte ‘Externe site’ in de rechterkolom.

Vervolgens moet u deze regel toevoegen onderaan uw .htaccess-bestand:

php_value max_execution_time 300

Sla het bestand op.

Deze code stelt eenvoudig de waarde voor maximale uitvoeringstijd in op 300 seconden (5 minuten). Bezoek nu de website om te zien of de fout is opgelost. Als de fout nog steeds aanwezig is, probeer dan de waarde te verhogen naar 600.

PHP.ini

Een andere methode om de maximale uitvoeringstijd overschreden fout in WordPress te repareren, is door het php.ini-bestand te wijzigen.

Het php.ini-bestand is een configuratiebestand dat de instellingen voor PHP op uw server definieert. Op veel WordPress-hostingplatforms zie je het mogelijk niet in de WordPress-map. In dat geval kan je een nieuw php.ini-bestand maken in de WordPress-hoofdmap. Bewerk daarna het php.ini-bestand en voeg de volgende regel toe.

1 max_execution_time = 60

Vergeet niet de wijzigingen op te slaan en naar de server te uploaden. Bezoek nu de website en kijk of de fout is verdwenen.

In de meeste gevallen zal het verhogen van de maximale uitvoeringstijd met behulp van een van deze twee methoden de fout oplossen. Als dit niet het geval is, moet u contact opnemen met uw WordPress-hostingprovider voor hulp.

NOG MEER LEESVOER

Klarna in België

Klarna in België

Mollie is de eerste payment provider die nu in België Klarna aanbiedt. Wat is Klarna: achteraf betalen? Klarna is een betaalmethode waarbij jouw...

Lees meer
WordPress 5.4

WordPress 5.4

De laatste WordPress update is verkrijgbaar, versie 5.4. Wat is er nieuw? Dat lees je in dit artikel Meer manieren om je berichten en pagina's tot...

Lees meer
Woocommerce 4.0

Woocommerce 4.0

Vandaag werd Woocoomerce 4.0 uitgebracht. Zie hier het officieel persbericht: "Vandaag zijn we verheugd om de beschikbaarheid van WooCommerce 4.0...

Lees meer
Maak unieke wachtwoorden

Maak unieke wachtwoorden

Maak een lang wachtwoord De vijand is niet iemand die een wachtwoord één voor één probeert te raden. Het is een programma dat automatisch enorme...

Lees meer
Woocommerce update 3.9

Woocommerce update 3.9

Wat is nieuw in 3.9: • In het blok Alle producten voor de Block Editor worden de producten van de winkel weergegeven in een raster, compleet met...

Lees meer